Harmonize Learning - Some Turnitin Submissions Stuck Processing – Incident details

All systems operational

Some Turnitin Submissions Stuck Processing

Resolved
Degraded performance
Started 9 days agoLasted 8 days

Affected

External Integrations

Degraded performance from 3:30 PM to 4:48 PM, Operational from 4:48 PM to 5:57 PM

TurnItIn

Degraded performance from 3:30 PM to 4:48 PM, Operational from 4:48 PM to 5:57 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We heard from Turnitin Technical Support this morning that a fix has been released. Our team has begun re-queueing discussion posts that are currently missing Turnitin scores. We'll be monitoring the resubmission process over the next few hours.

  • Investigating
    Investigating

    Our teams detected that several Turnitin submissions for discussion posts have run into a processing error, though the majority are completing successfully. Our team has filed a ticket with Turnitin Support and they are actively investigating the issue.