Harmonize Learning - Problems submitting with TurnItIn – Incident details
Report an issue
Get updates
Email
RSS
Atom
Report an issue
Get updates
Experiencing partially degraded performance
Problems submitting with TurnItIn
Resolved
Operational
Started 7 months ago
Lasted less than a minute
Affected
External Integrations
Operational from 3:19 PM to 3:19 PM
TurnItIn
Operational from 3:19 PM to 3:19 PM
Updates
Update
April 18, 2024 at 3:30 PM
Update
April 18, 2024 at 3:30 PM
This incident has been resolved.
Resolved
April 18, 2024 at 3:19 PM
Resolved
April 18, 2024 at 3:19 PM
This incident has been resolved.